NEED HELP?
We're available 24/7. Call us at
800-234-6926 or send us an email.

NYCM Insurance is Upgrading Web Browser Security to TLS 1.2 to Protect YOU!

NYCM Insurance is committed to protecting the things that matter most to you including information transmitted to www.nycm.com or any of its affiliated pages. Because of this commitment, NYCM Insurance will be requiring all customers to transmit data in a way that complies with current security protocols outlined by the Payment Card Industry (PCI) standards. As a result, NYCM Insurance will be disabling all Transport Layer Security (TLS) versions less than 1.2 by December 31, 2017. After this date, any connection request from an unsupported browser will not be able to connect to NYCM Insurance. Below is a list of Operating Systems and Web Browsers compatible with the changes being made by NYCM Insurance.

Operating Systems:

Web Browsers:

To check the version and enable the TLS 1.2 protocol on your Web Browser, see the below assistance or search the Internet for "How to enable TLS 1.2 for browser".

Quickly test your browsers security compatibility with TLS 1.2 compliance by clicking here. Select "Test your browser".

Internet Explorer:

  1. On the main menu, select Tools > Internet Options.
  2. In the Internet Options box, select the Advanced tab.
  3. In the Security category, uncheck "Use SSL 3.0" and check Use TLS 1.0, TLS 1.1 and Use TLS 1.2 (if available).
  4. If these Security categories are not listed, you must update your browser to a current version.

Google Chrome:

  1. With Google Chrome open, click Alt F and select Settings.
  2. Scroll down and select Show advanced settings.
  3. Scroll down to the System section and click Open proxy settings.
  4. Select the Advanced tab.
  5. Scroll down to the Security category; manually check the option box for Use TLS 1.1 and Use TLS 1.2.
  6. Click OK.
  7. Close your browser and restart Google Chrome.
  8. If these Security categories are not listed, you must update your browser to a current version.

Mozilla Firefox:

  1. With Firefox open, type "about:config" in the address bar and press Enter.
  2. In the Search field, enter "tls" and then find and double-click the entry for security.tls.version.min.
  3. Set the integer value to 2 to force protocol of TLS 1.2.
  4. Close your browser and restart Mozilla Firefox.
  5. If these options are not available, you must update your browser to a current version.

If you have an immediate insurance need, you can always contact our 24 hour Customer Service Team at 800-234-6926.

MORE
© 2018 NYCM Insurance, 1899 Central Plaza East, Edmeston, NY 13335